Technical and network requirements for NextGen

VizZle NextGen is optimized for the following browsers:

  • Chrome (version 56 or later)
  • Safari (version 9 or higher)

The iPad app requires iOS 9.1 or later.

 

If you're behind a network firewall or proxy, please speak with your IT support to allow traffic to the following URLs:

https://*.govizzle.com

https://*.monarchteachtech.com

https://*.monarchtt.com

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk